Windows Administration

Es gibt 2 Posts mit diesem Tag.

pwrshll: Office365 Exchange Online Connetor mehrere Domains importieren

pwrshll: Office365 Exchange Online Connetor mehrere Domains importieren

Da ich online nicht so richtig fündig geworden bin, musste ich selbst ran und ein wenig "spielen". Hintergrund ist: wir wollen mit einer PartnerOrg Mandatory TLS von uns zu denen und umgekehr bauen und diese PartnerOrg hat einfach sehr viele Domains. Ist halt ein großes Unternehmen.

Die AdminUI von O365 hat leider nur die Möglichkeit Domains einzeln einzufügen für die Empfangsdomains, was bei mehr als fünf Domains schon scheiße nervig ist. Also: Powershell.

Zunächst connecten wir uns nach exchange online:

connect-exchangeonline

Wir haben in diesem Beispiel einfach schon einmal einen Connector mit einer recipientdomain im AdminUI gebaut, wollen also nur die Restlichen 5000 Domains hinzufügen. Also holen wir uns mal alle Connectors rein mit:

Get-OutboundConnector

Powershell zeigt uns unsere Connectoren und genauer reinsehen können wir mit -identity:

Get-OutboundConnector -Identity "Mein Connector" | fl

Wenn also ein Get-Befehl funktioniert, dann sollte auch ein Set-Befehl gehen, oder? Genau dafür gibt es hier Set-OutboundConnector, mit dem wir den Connector manipulieren können. Wir benötigen hier den Parameter -RecipientDomains. Den können wir nun benutzen um hunderte Domains in den Connector einzufügen:

Set-OutboundConnector -Identity "Mein Connector" -RecipientDomains domain1.de,domain2.de,meinedomain.net,domainirgendwasirgendwie.xyz,blabladomain.it,usw.xyz

Wenn man also wirklich viele Domains hat, die man dort einfügen muss, dann geht das wieder mit PS deutlich besser.

"Diese Smartcard konnte nicht verwendet werden" mit YubiKey

"Diese Smartcard konnte nicht verwendet werden" mit YubiKey

update: traue mich fast kaum es zu sagen, aber es lag daran, dass NUMPAD bei der Userin nicht aktiv war naja

Oder "This Smart Card cannot be used". Was für ein besc***** Fehler.

Also, der Hintergrund ist, dass wir auf der Arbeit allen unseren Usern einen YubiKey deployen und natürlich auch dessen Smartcardfunktionalität nutzen wollen. Es wurde eine CA erstellt, es wurden Keys beschafft. Und zum Großteil funktioniert es auch für die User.

Eine der Userinnen hat aber das Problem, dass sie sich im HomeOffice nicht mit der Smartcard an Windows 10 anmelden kann. Sie kann via VPN die Zertifikate anfordern und Programme mit der SC ausführen, aber anmelden kann sie sich nicht. Sie bekommt die Meldung "Diese Smartcard kann nicht verwendet werden"

Hier ist also was ich bis jetzt versucht habe:

  • YubiKey Treiber neu installiert
  • Zertifikate (erfolgreich) neu angefordert
  • CA auf den Yubikey geladen (certutil -scroots update)
  • Wenn man nun ohne VPN certutil -scinfo ausführt, so wird die Kette als gültig angezeigt

Nun gehe ich davon aus, dass dieser Fehler auftritt, da besagte Userin die SC nicht am Arbeitsplatz im Büro konfiguriert hat, sondern via VPN aus dem Homeoffice heraus. Das ist etwas ins Blaue aber momentan mein einziger Strohhalm an dem ich mich festhalte. Sie wohnt leider etwas weg, sodass sie nicht sponti hier aufschlagen kann.

Ich update den Post hier mal sobald sie im Büro anwesend war.